mps-youtube

Depuis quelque temps je rencontrais pas mal de souci avec mps-youtube et j’ai décidé de résoudre tous les ennuis que je rencontrais ce soir. Alors je partage tout se que j’ai fais, avant de l’oublier 🙂

Pour commencer mps-youtube 0.2.5 ne fonctionne pas sur MacOSX lors de son installation, on recoi plein de messages d’erreurs. Je ne me suis pas amusé à chercher d’où viennent ces erreurs, alors que la version 0.2.4 fonctionne très bien … (Je choisi le chemin facile je l’avoue …)

Pour commencer!

Installons cette version 0.2.4 avec la commande suivante:

sudo easy_install mps-youtube==0.2.4

Une fois que c’est fait installez mpv avec Port ou Brew.

sudo port install mpv

ou

brew install mpv

Une fois que c’est fait, mps-youtube install mplayer par défaut et le selectionne… Or il y a un bug qui rend mplayer casiment innutilisable. On obtient un message d’erreur du genre « mplayer ne peut lire ce codec » en anglais (je n’ai plus le message en tête exactement).

Si c’est le cas:

entrez dans mps-youtube avec la commande

mpsyt

Une fois dans mps-youtube tapez la commande suivante:

set player mpv

Voilà! mps-youtube sera installé dans une version qui fonctionne sur votre mac et aura un player qui fonctionne correctement sans message d’erreur sur 80% des musiques youtube :-))

 

 

EDIT: Pour la version 0.2.6 de mps-youtube il est nécessaire de l’installer avec pip3, pour se faire tapez la commande suivante [ (sudo) pip3 install mps-youtube ] il est possible d’installer avec pip3.5 si celui-ci est disponible.

EDIT2: petit oubli de taille … il faut avoir installé youtube-dl avant que mps-youtube fonctionne, car il s’appuie sur ce paquet. un petit coup de:

pip3.5 install youtube-dl

Voilà c’est réglé!

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

* Copy This Password *

* Type Or Paste Password Here *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.